re = /(https:\/\/www\.test\.com\/items\/)[0-9]+/
str = 'https://www.test.com/items/1.html
https://www.test.com/items/1123.html
https://www.test.com/items/234.html
https://www.bar.com/items/234.html
https://www.test.com/items.html
https://www.bar.com/items/234.html
https://www.test.com/items.html'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end