using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?<=[a-zA-Z0-9={}])\s+(?=[a-zA-Z0-9={}(])|[\n\r]+|(?<=[{}])|(?=[{}])|(?<=[=])|(?=[=]))(?=(?:[^""]*""[^""]*"")*[^""]*$)";
string substitution = @"\n";
string input = @"print ""hello""
print ""x+2 / 5 = 3""";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}