import Foundation
let pattern = #"((?<=[a-zA-Z0-9={}])\s+(?=[a-zA-Z0-9={}(])|[\n\r]+|(?<=[{}])|(?=[{}])|(?<=[=])|(?=[=]))(?=(?:[^"]*"[^"]*")*[^"]*$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
print "hello"
print "x+2 / 5 = 3"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)