import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?<=[a-zA-Z0-9=\\{\\}])\\s+(?=[a-zA-Z0-9=\\{\\}(])|[\\n\\r]+|(?<=[\\{\\}])|(?=[\\{\\}])|(?<=[=])|(?=[=]))(?=(?:[^\"]*\"[^\"]*\")*[^\"]*$)";
final String string = "print \"hello\"\n"
+ "print \"x+2 / 5 = 3\"";
final String subst = "\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}