use strict;
my $str = 'print "hello"
print "x+2 / 5 = 3"';
my $regex = qr/((?<=[a-zA-Z0-9={}])\s+(?=[a-zA-Z0-9={}(])|[\n\r]+|(?<=[{}])|(?=[{}])|(?<=[=])|(?=[=]))(?=(?:[^"]*"[^"]*")*[^"]*$)/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";