$re = '/((?<=[a-zA-Z0-9={}])\s+(?=[a-zA-Z0-9={}(])|[\n\r]+|(?<=[{}])|(?=[{}])|(?<=[=])|(?=[=]))(?=(?:[^"]*"[^"]*")*[^"]*$)/m';
$str = 'print "hello"
print "x+2 / 5 = 3"';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;