re = /((?<=[a-zA-Z0-9={}])\s+(?=[a-zA-Z0-9={}(])|[\n\r]+|(?<=[{}])|(?=[{}])|(?<=[=])|(?=[=]))(?=(?:[^"]*"[^"]*")*[^"]*$)/m
str = 'print "hello"
print "x+2 / 5 = 3"'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result