#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)((^[aeiou])|(\s+[aeiou]))\w+[aeiou]\b"
Local $sString = "Arline ate eight apples and one orange while Anita hadn't any" & @CRLF & _
"Not match" & @CRLF & _
"a_match_i" & @CRLF & _
"a_no_match_" & @CRLF & _
"A_match_I" & @CRLF & _
"A_NO_match_"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")