import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)((^[aeiou])|(\\s+[aeiou]))\\w+[aeiou]\\b";
final String string = "Arline ate eight apples and one orange while Anita hadn't any\n"
+ "Not match\n"
+ "a_match_i\n"
+ "a_no_match_\n"
+ "A_match_I\n"
+ "A_NO_match_";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}