using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)((^[aeiou])|(\s+[aeiou]))\w+[aeiou]\b";
string input = @"Arline ate eight apples and one orange while Anita hadn't any
Not match
a_match_i
a_no_match_
A_match_I
A_NO_match_";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}