const regex = new RegExp('(?i)((^[aeiou])|(\\s+[aeiou]))\\w+[aeiou]\\b', 'gm')
const str = `Arline ate eight apples and one orange while Anita hadn't any
Not match
a_match_i
a_no_match_
A_match_I
A_NO_match_`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}