import re
regex = re.compile(r"(?i)((^[aeiou])|(\s+[aeiou]))\w+[aeiou]\b", flags=re.MULTILINE)
test_str = ("Arline ate eight apples and one orange while Anita hadn't any\n"
"Not match\n"
"a_match_i\n"
"a_no_match_\n"
"A_match_I\n"
"A_NO_match_")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")