using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" \s*(( )?[0-9]+(?:\.\d+)?(?:\s*(?:l[ lb ]|lb))?(, )?)+\b";
string input = @"<br><span style=""font-size: 15px;""><span style=""color: #000000;"">• 8.5 lb, 25.4 lb 8.5 lb, 25.4 lb 8.5 lb, 25.4 lb</ ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}