re = / \s*(( )?[0-9]+(?:\.\d+)?(?:\s*(?:l[ lb ]|lb))?(, )?)+\b/
str = '<br><span style="font-size: 15px;"><span style="color: #000000;">• 8.5 lb, 25.4 lb 8.5 lb, 25.4 lb 8.5 lb, 25.4 lb</ '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end