// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r" \s*(( )?[0-9]+(?:\.\d+)?(?:\s*(?:l[ lb ]|lb))?(, )?)+\b").unwrap();
let string = "<br><span style=\"font-size: 15px;\"><span style=\"color: #000000;\">• 8.5 lb, 25.4 lb 8.5 lb, 25.4 lb 8.5 lb, 25.4 lb</ ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}