package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<prefix>R-)?(?<series>E[1-9][0-9]*)\.(?<ocpu>[1-9][0-9]*)-(?<memory>[1-9][0-9]*)(?:GB)?(?<servermem>\\([0-9-]+\\))?`)
var str = `E3.48-768
E3.48-768-HA
R-E3.128-2048(4-256)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}