re = /(?<prefix>R-)?(?<series>E[1-9][0-9]*)\.(?<ocpu>[1-9][0-9]*)-(?<memory>[1-9][0-9]*)(?:GB)?(?<servermem>\\([0-9-]+\\))?/m
str = 'E3.48-768
E3.48-768-HA
R-E3.128-2048(4-256)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end