import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<prefix>R-)?(?<series>E[1-9][0-9]*)\\.(?<ocpu>[1-9][0-9]*)-(?<memory>[1-9][0-9]*)(?:GB)?(?<servermem>\\\\([0-9-]+\\\\))?";
final String string = "E3.48-768\n"
+ "E3.48-768-HA\n"
+ "R-E3.128-2048(4-256)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}