import re
regex = re.compile(r"(?<prefix>R-)?(?<series>E[1-9][0-9]*)\.(?<ocpu>[1-9][0-9]*)-(?<memory>[1-9][0-9]*)(?:GB)?(?<servermem>\\([0-9-]+\\))?", flags=re.MULTILINE)
test_str = ("E3.48-768\n"
"E3.48-768-HA\n"
"R-E3.128-2048(4-256)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")