const regex = /([^rs])(?=\1+)|(rr)(?=r+)|(ss)(?=s+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^rs])(?=\\1+)|(rr)(?=r+)|(ss)(?=s+)', 'g')
const str = `oiiiiiiii amiggggos passssado Carrrrrrrros`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);