$re = '/([^rs])(?=\1+)|(rr)(?=r+)|(ss)(?=s+)/';
$str = 'oiiiiiiii amiggggos passssado Carrrrrrrros';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;