use strict;
my $str = 'oiiiiiiii amiggggos passssado Carrrrrrrros';
my $regex = qr/([^rs])(?=\1+)|(rr)(?=r+)|(ss)(?=s+)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";