re = /([^rs])(?=\1+)|(rr)(?=r+)|(ss)(?=s+)/
str = 'oiiiiiiii amiggggos passssado Carrrrrrrros'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result