using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a href=([^<]*)test2.com([^<]*)<\/a>";
string input = @"<a href=""test1.com"">test1</a><a href=""test2.com"">test2</a>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}