// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<a href=([^<]*)test2.com([^<]*)<\/a>").unwrap();
let string = "<a href=\"test1.com\">test1</a><a href=\"test2.com\">test2</a>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}