$re = '/<a href=([^<]*)test2.com([^<]*)<\/a>/';
$str = '<a href="test1.com">test1</a><a href="test2.com">test2</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);