const regex = /<a href=([^<]*)test2.com([^<]*)<\/a>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a href=([^<]*)test2.com([^<]*)<\\\/a>', 'g')
const str = `<a href="test1.com">test1</a><a href="test2.com">test2</a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}