package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<a href=([^<]*)test2.com([^<]*)<\/a>`)
var str = `<a href="test1.com">test1</a><a href="test2.com">test2</a>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}