re = /<a href=([^<]*)test2.com([^<]*)<\/a>/
str = '<a href="test1.com">test1</a><a href="test2.com">test2</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end