re = /.*Linkpop.*\n.*>(.*)<.*/
str = '<table style="border-spacing:0;">
<tbody>
<tr>
<td>• Linkpop:</td>
<td style="text-align:right;">0</td>
</tr>
<tr>
<td style="padding-right:10px;">• Domainpop:</td>
<td style="text-align:right;">0</td>
</tr>
</tbody>
</table>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end