// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".*Linkpop.*\n.*>(.*)<.*").unwrap();
let string = "<table style=\"border-spacing:0;\">
<tbody>
<tr>
<td>• Linkpop:</td>
<td style=\"text-align:right;\">0</td>
</tr>
<tr>
<td style=\"padding-right:10px;\">• Domainpop:</td>
<td style=\"text-align:right;\">0</td>
</tr>
</tbody>
</table>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}