import Foundation
let pattern = #".*Linkpop.*\n.*>(.*)<.*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<table style="border-spacing:0;">
<tbody>
<tr>
<td>• Linkpop:</td>
<td style="text-align:right;">0</td>
</tr>
<tr>
<td style="padding-right:10px;">• Domainpop:</td>
<td style="text-align:right;">0</td>
</tr>
</tbody>
</table>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)