using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=^.*Snapdragon.*).*(?=\n)";
string input = @"Is there any way to fetch the line with a key value, for eg in the below line
“local parameter and identifier is Snapdragon” — I need to fetch the entire line
using the word Snapdragon which is the key value, each time that key value can
vary and there are close to 100 lines in text file. Any way to retrieve the entire line using the key value?";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}