re = /(?=^.*Snapdragon.*).*(?=\n)/m
str = 'Is there any way to fetch the line with a key value, for eg in the below line
“local parameter and identifier is Snapdragon” — I need to fetch the entire line
using the word Snapdragon which is the key value, each time that key value can
vary and there are close to 100 lines in text file. Any way to retrieve the entire line using the key value?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end