import re
regex = re.compile(r"(?=^.*Snapdragon.*).*(?=\n)", flags=re.MULTILINE)
test_str = ("Is there any way to fetch the line with a key value, for eg in the below line\n"
"“local parameter and identifier is Snapdragon” — I need to fetch the entire line \n"
"using the word Snapdragon which is the key value, each time that key value can \n"
"vary and there are close to 100 lines in text file. Any way to retrieve the entire line using the key value?")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")