import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=^.*Snapdragon.*).*(?=\\n)";
final String string = "Is there any way to fetch the line with a key value, for eg in the below line\n"
+ "“local parameter and identifier is Snapdragon” — I need to fetch the entire line \n"
+ "using the word Snapdragon which is the key value, each time that key value can \n"
+ "vary and there are close to 100 lines in text file. Any way to retrieve the entire line using the key value?";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}