using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^0-9A-Z0-9\à\è\é\ì\ò\ù\€_\,\;\:\!\.\-\+\*\/\(\)\[\]\?=\@\%\&#\s]";
string substitution = @"!!!";
string input = @"punteggiatura !.,?:;@+-%=
#
<>
includere sconto 50%
perché però qualità più mercoledì
10 €
come ordine dell'altra volta
""citazione""
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.CultureInvariant | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution, 1);
}
}