use strict;
my $str = 'punteggiatura !.,?:;@+-%=
#
<>
includere sconto 50%
perché però qualità più mercoledì
10 €
come ordine dell\'altra volta
"citazione"
';
my $regex = qr/[^0-9A-Z0-9\à\è\é\ì\ò\ù\€_\,\;\:\!\.\-\+\*\/\(\)\[\]\?=\@\%\&#\s]/iump;
my $subst = '!!!';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";