import re
regex = re.compile(r"[^0-9A-Z0-9\à\è\é\ì\ò\ù\€_\,\;\:\!\.\-\+\*\/\(\)\[\]\?=\@\%\&#\s]", flags=re.IGNORECASE | re.UNICODE | re.MULTILINE)
test_str = ("punteggiatura !.,?:;@+-%=\n"
"#\n"
"<> \n"
"includere sconto 50%\n"
"perché però qualità più mercoledì\n"
"10 €\n"
"come ordine dell'altra volta\n"
"\"citazione\"\n")
subst = "!!!"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)