import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = ##"[^0-9A-Z0-9\à\è\é\ì\ò\ù\€_\,\;\:\!\.\-\+\*\/\(\)\[\]\?=\@\%\&#\s]"##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = ##"""
punteggiatura !.,?:;@+-%=
#
<>
includere sconto 50%
perché però qualità più mercoledì
10 €
come ordine dell'altra volta
"citazione"
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"!!!"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}