package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`id="aqiPm10"\s+class="aqi">(\d+)<\/div>`)
var str = `<div id="aqiPm10" class="aqi">9</div>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}