import Foundation
let pattern = #"id="aqiPm10"\s+class="aqi">(\d+)<\/div>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<div id="aqiPm10" class="aqi">9</div>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}