using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!^).(\(\+\d{1,3}\)?)( *(,|$))";
string substitution = @"";
string input = @" (+966)533356235, (+966)123123, (+966), (+966)";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}