use strict;
my $str = ' (+966)533356235, (+966)123123, (+966), (+966)';
my $regex = qr/(?!^).(\(\+\d{1,3}\)?)( *(,|$))/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";