$re = '/(?!^).(\(\+\d{1,3}\)?)( *(,|$))/m';
$str = ' (+966)533356235, (+966)123123, (+966), (+966)';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;