re = /(?!^).(\(\+\d{1,3}\)?)( *(,|$))/m
str = ' (+966)533356235, (+966)123123, (+966), (+966)'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result