import re
regex = re.compile(r"(?!^).(\(\+\d{1,3}\)?)( *(,|$))", flags=re.MULTILINE)
test_str = " (+966)533356235, (+966)123123, (+966), (+966)"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)