#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\[?(\w+,)*(abc|def)(,\w+)*]?="
Local $sString = "%% good examples" & @CRLF & _
"x=1" & @CRLF & _
"aabc=1" & @CRLF & _
"abc=1" & @CRLF & _
"[other,abc]=deal(1,2)" & @CRLF & _
"" & @CRLF & _
"%% bad examples" & @CRLF & _
"[x,aabcc]=deal(1,2)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")