package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\[?(\w+,)*(abc|def)(,\w+)*]?=`)
var str = `%% good examples
x=1
aabc=1
abc=1
[other,abc]=deal(1,2)
%% bad examples
[x,aabcc]=deal(1,2)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}