// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\[?(\w+,)*(abc|def)(,\w+)*]?=").unwrap();
let string = "%% good examples
x=1
aabc=1
abc=1
[other,abc]=deal(1,2)
%% bad examples
[x,aabcc]=deal(1,2)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}